Difference between revisions of "Talk:Building EDuke32 on Windows"

From EDukeWiki
Jump to navigation Jump to search
(New page: I'm getting theese errors when trying to build eduke32 on windows using openwatcom C:\eduke32_src_20080206\build>wmake -f Makefile.watcom Open Watcom Make Version 1.7 Portions Copyrigh...)
 
 
Line 1: Line 1:
I'm getting theese errors when trying to build eduke32 on windows using openwatcom
+
==mail from terminx which may help get the build process working with the latest eduke32, i haven't investigated it yet==
  
  C:\eduke32_src_20080206\build>wmake -f Makefile.watcom
+
Which ones are you missing? You need the OpenAL stuff and OggVorbis-win32sdk-1.0.1.zip at the least, perhaps some other SDKs as well.
Open Watcom Make Version 1.7
+
Richard C. Gobeille
Portions Copyright (c) 1988-2002 Sybase, Inc. All Rights Reserved.
+
http://www.eduke32.com
Source code is available under the Sybase Open Watcom Public License.
+
terminx@gmail.com
See http://www.openwatcom.org/ for details.
+
 
        %null
+
 
+
 
C:\eduke32_src_20080206\build>
+
peter green wrote:
+
> It seems the latest version of eduke32 requires some new 3rd party libraries to build, where should I get theese from?
C:\eduke32_src_20080206\eduke32>wmake -f Makefile.watcom
 
Open Watcom Make Version 1.7
 
Portions Copyright (c) 1988-2002 Sybase, Inc. All Rights Reserved.
 
Source code is available under the Sybase Open Watcom Public License.
 
See http://www.openwatcom.org/ for details.
 
Makefile.watcom(85): Error(E09): Ignoring out of place Path Specifier
 
Makefile.watcom(85): Warning(W79): Makefile may be Microsoft; try /ms switch
 
Makefile.watcom(88): Error(E09): Ignoring out of place Path Specifier
 
Makefile.watcom(88): Warning(W79): Makefile may be Microsoft; try /ms switch
 
Makefile.watcom(88): Error(E09): Ignoring out of place Path Specifier
 
Makefile.watcom(88): Warning(W79): Makefile may be Microsoft; try /ms switch
 
Error(E02): Make execution terminated
 
 
-- [[User:Plugwash|Plugwash]] 11:03, 22 March 2008 (PDT)
 

Latest revision as of 08:54, 19 June 2008

mail from terminx which may help get the build process working with the latest eduke32, i haven't investigated it yet

Which ones are you missing? You need the OpenAL stuff and OggVorbis-win32sdk-1.0.1.zip at the least, perhaps some other SDKs as well. Richard C. Gobeille http://www.eduke32.com terminx@gmail.com


peter green wrote: > It seems the latest version of eduke32 requires some new 3rd party libraries to build, where should I get theese from?